Skip to main content
← All vulnerabilities
CVE-2024-28149GHSA-8VCG-V7G4-3VR7

Jenkins HTML Publisher Plugin 1.16 through 1.32 (both inclusive) does not properly sanitize input, allowing attackers with Item/Configure pe

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.32.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Jenkins HTML Publisher Plugin 1.16 through 1.32 (both inclusive) does not properly sanitize input, allowing attackers with Item/Configure permission to implement cross-site scripting (XSS) attacks and to determine whether a path on the Jenkins controller file system exists.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Jenkins Project Jenkins HTML Publisher Plugin

    From 1.16 · through 1.32

  • org.jenkins-ci.plugins:htmlpublisherMaven

    From 1.16 · fixed in 1.32.1

References 2

jenkins.io

openwall.com