Skip to main content
← All vulnerabilities
CVE-2024-28098GHSA-G627-R579-RW35

Apache Pulsar: Improper Authorization For Topic-Level Policy Management

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.10.6, 2.11.4, 3.0.3, 3.1.3, 3.2.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Pulsar

    From 2.7.1 · fixed in 2.10.6; From 2.11.0 · fixed in 2.11.4; From 3.0.0 · fixed in 3.0.3; From 3.1.0 · fixed in 3.1.3; From 3.2.0 · fixed in 3.2.1

  • org.apache.pulsar:pulsar-brokerMaven

    From 3.2.0 · fixed in 3.2.1

  • org.apache.pulsar:pulsar-brokerMaven

    From 3.1.0 · fixed in 3.1.3

  • org.apache.pulsar:pulsar-brokerMaven

    From 3.0.0 · fixed in 3.0.3

  • org.apache.pulsar:pulsar-brokerMaven

    From 2.11.0 · fixed in 2.11.4

  • org.apache.pulsar:pulsar-brokerMaven

    From 2.7.1 · fixed in 2.10.6

References 3

lists.apache.org

pulsar.apache.org

openwall.com