Skip to main content
← All vulnerabilities
CVE-2024-27354GHSA-2528-JW5Q-WW88

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.23, 2.0.47, 3.0.36
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • phpseclib/phpseclibPackagist

    From 0.1.1 · fixed in 1.0.23

  • phpseclib/phpseclibPackagist

    From 2.0.0 · fixed in 2.0.47

  • phpseclib/phpseclibPackagist

    From 3.0.0 · fixed in 3.0.36

References 4

GitHub · phpseclib/phpseclib

gist.github.com

lists.debian.org