Skip to main content
← All vulnerabilities
CVE-2024-26580GHSA-P2GX-4434-PF6G

Apache InLong: Logged-in user could exploit an arbitrary file read vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.11.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9673

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache InLong

    From 1.4.0 · through 1.10.0

  • org.apache.inlong:manager-commonMaven

    From 1.8.0 · fixed in 1.11.0

References 2

lists.apache.org

openwall.com