Skip to main content
← All vulnerabilities
CVE-2024-26016PYSEC-2026-1158BIT-SUPERSET-2024-26016GHSA-3V9R-885J-762G

Apache Superset: Improper authorization validation on dashboards and charts import

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.4, 3.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Superset

    fixed in 3.0.4; From 3.1.0 · fixed in 3.1.1

  • apache-supersetPyPI

    fixed in 3.0.4; From 3.1.0 · fixed in 3.1.1

  • apache-supersetPyPI

    fixed in 3.0.4

  • apache-supersetPyPI

    From 3.1.0 · fixed in 3.1.1

References 2

lists.apache.org

openwall.com