CVE-2024-25723PYSEC-2026-2072GHSA-VF7J-CMRJ-PMMM
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{us
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.42.2, 0.43.1, 0.44.4, 0.46.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub, 1 Nuclei template
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: poc
- Automatable: no
- Technical impact: total
Summary
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
- zenmlPyPI
fixed in 0.42.2; From 0.43.0 · fixed in 0.43.1; From 0.44.0 · fixed in 0.44.4; From 0.45.0 · fixed in 0.46.7
- zenmlPyPI
fixed in 0.42.2
- zenmlPyPI
From 0.43.0 · fixed in 0.43.1
- zenmlPyPI
From 0.45.0 · fixed in 0.46.7
- zenmlPyPI
From 0.44.0 · fixed in 0.44.4