Skip to main content
← All vulnerabilities
CVE-2024-25621GHSA-PWHC-RPQ9-4C8WGO-2025-4100

containerd affected by a local privilege escalation via wide permissions on CRI directory

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.7.29, 2.0.7, 2.1.5, 2.2.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • containerd containerd

    fixed in 1.7.29; From 2.0.0-beta.0 · fixed in 2.0.7; From 2.1.0-beta.0 · fixed in 2.1.5; From 2.2.0-beta.0 · fixed in 2.2.0

  • github.com/containerd/containerdGo

    fixed in 1.7.29

  • github.com/containerd/containerd/v2Go

    fixed in 2.0.7

  • github.com/containerd/containerd/v2Go

    From 2.1.0-beta.0 · fixed in 2.1.5

  • github.com/containerd/containerd/v2Go

    From 2.2.0-beta.0 · fixed in 2.2.0

  • github.com/containerd/containerd/v2Go

    fixed in 2.0.7; From 2.1.0-beta.0 · fixed in 2.1.5; From 2.2.0-beta.0 · fixed in 2.2.0

References 3

GitHub · containerd/containerd