CVE-2024-25152GHSA-P28X-4R5H-PH6J
Stored cross-site scripting (XSS) vulnerability in Message Board widget in Liferay Portal 7.2.0 through 7.4.2, and older unsupported version
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 7.3.10.u4, 7.2.10.fp17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Stored cross-site scripting (XSS) vulnerability in Message Board widget in Liferay Portal 7.2.0 through 7.4.2, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 17, and older unsupported versions allows remote authenticated users to inject arbitrary web script or HTML via the filename of an attachment.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Liferay Portal
From 7.2.0 · through 7.4.2
- Liferay DXP
From 7.3.10 · through 7.3.10-dxp-2; From 7.2.10 · through 7.2.10-dxp-16
- com.liferay.portal:release.portal.bomMaven
through 7.4.2
- com.liferay.portal:release.dxp.bomMaven
From 7.3.0 · fixed in 7.3.10.u4
- com.liferay.portal:release.dxp.bomMaven
From 7.2.0 · fixed in 7.2.10.fp17