CVE-2024-24773PYSEC-2026-1160BIT-SUPERSET-2024-24773GHSA-5474-F7G5-273Q
Apache Superset: Improper validation of SQL statements allows for unauthorized access to data
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.0.4, 3.1.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Apache Software Foundation Apache Superset
fixed in 3.0.4; From 3.1.0 · fixed in 3.1.1
- apache-supersetPyPI
fixed in 3.0.4; From 3.1.0 · fixed in 3.1.1
- apache-supersetPyPI
fixed in 3.0.4
- apache-supersetPyPI
From 3.1.0 · fixed in 3.1.1