CVE-2024-24772PYSEC-2026-1185BIT-SUPERSET-2024-24772GHSA-M6JM-3V38-76J4
Apache Superset: Improper Neutralisation of custom SQL on embedded context
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.0.4, 3.1.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Apache Software Foundation Apache Superset
fixed in 3.0.4; From 3.1.0 · fixed in 3.1.1
- apache-supersetPyPI
fixed in 3.0.4; From 3.1.0 · fixed in 3.1.1
- apache-supersetPyPI
fixed in 3.0.4
- apache-supersetPyPI
From 3.1.0 · fixed in 3.1.1