Skip to main content
← All vulnerabilities
CVE-2024-24575

libgit2 is vulnerable to a denial of service attack in `git_revparse_single`

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.6.5, 1.7.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • libgit2 libgit2

    From 1.4.0 · fixed in 1.6.5; From 1.7.0 · fixed in 1.7.2

References 9

GitHub · libgit2/libgit2

lists.fedoraproject.org