Skip to main content
← All vulnerabilities
CVE-2024-23819GHSA-7X76-57FR-M5R5

GeoServer Stored Cross-Site Scripting (XSS) vulnerability in MapML HTML Page

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.23.4, 2.24.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • geoserver geoserver

    fixed in 2.23.4

  • org.geoserver.extension:gs-mapmlMaven

    fixed in 2.23.4

  • org.geoserver.extension:gs-mapmlMaven

    From 2.24.0 · fixed in 2.24.1

References 5

GitHub · geoserver/geoserver

osgeo-org.atlassian.net